Instalace FlexiBee na Ubuntu 20.04 není momentálně zdánlivě možná. V závislosti na postupu, jaký pro instalaci zvolíte, narazíte na hlášku podobné této:

V repozitářích Ubuntu 20.04 je pouze PostgreSQL 12, tuto verzi ale FlexiBee momentálně nepodporuje. Pomůžeme si přidáním oficiálního PostgreSQL repozitáře, který obsahuje na výběr více podporovaných verzí PostgreSQL.

Stačí navštívit stránku https://www.postgresql.org/ , tam zvolit sekci Download a vybrat Váš operační systém - Ubuntu. V menu Choose your Ubuntu version zvolte možnost Focal (20.04).

Podle návodu založte soubor /etc/apt/sources.list.d/pgdg.list s požadovaným obsahem. Dále je potřeba přidat klíč repozitáře a pak už jen provést aktualizaci apt cache repozitářů.

Během instalace Vás bude systém varovat o instalaci "Obsolete" verze 10 PostgreSQL, která bude ovšem podporována výrobcem minimálně příští dva roky. Dále už jen zvolte typ instalace a máte hotovo, FlexiBee server je připraven k provozu.

Našli jste odpověď?