Operační systémy

Pro běh ekonomického systému Flexi budete na jednotlivých systémech potřebovat:

Windows

  • Windows 8.1Windows 10 (před aktualizací Windows 10 Fall Creators Update aktualizujte Flexi na verzi 2017.2.4.2 nebo novější).

  • Windows Server 2012Windows Server 2016,

  • 32bitová i 64bitová architektura,

macOS

  • macOS 10.12 Sierra11.5 Big Sur,

  • procesor Intel Core Duo a novější, včetně procesorů M1 [Jaký mám systém?],

  • pro instalaci právo administrátora (root).

Linux

  • Vhodná Linuxová distribuce (DEB nebo RPM balíčky):

  • Ubuntu (a jeho deriváty) 16.04, 18.04 a 20.04, Debian 9 až 10, Fedora 30 až 32, RHEL / CentOS 7 až 8.

  • 32bitová i 64bitová architektura.

  • právo administrátora pro instalaci (root).

  • X-Window System (pouze pro klientskou instalaci).


Java

Aplikace Flexi jsou napsané v programovacím jazyce Java a vyžadují v operačním systému prostředí pro spouštění Java aplikací, tzv. Java Runtime Environment (JRE). Nalézt jej lze také pod označením Java Platform, Standard Edition (Java SE) nebo zkráceně jen Java. Instalaci zajišťuje, v případě potřeby, instalační balíček.

Pro běh Flexi je zapotřebí prostředí Java 8 (Update 141 nebo vyšší). Java 7 již od roku 2019 nelze použít, pro nové verze je zapotřebí aktualizovat.


Databáze

Flexi server využívá pro ukládání dat databázový systém PostgreSQL. Jeho instalaci zajisťuje, v případě potřeby, instalační balíček.

Podporujeme PostgreSQL ve verzích 8.3 až 10. Kompatibilita s verzí 11 zatím nebyla zajištěna. Podporu starších, již nepodporovaných, verzí PostgreSQL 8.3 až 9.3 budeme ukončovat.

Aktuálně instalované verze:

Windows

9.3 pro nové instalace, jinak 8.3

Mac OS X

9.4 (starší verze instalátor automaticky aktualizuje)

Linux

8.3 až 10 (dle dostupných balíčků). Od verze 2021.9 byla přidána podpora s novějšími verzemi databáze 11, 12 a 13.


Hardware

Lokální instalace

Minimální požadovaná konfigurace:

  • osobní počítač s procesorem Intel, AMD nebo kompatibilním (tj. Pentium III a vyšší) s frekvencí minimálně 1.2 GHz,

  • 4 GB RAM (2 GB pro Flexi),

  • 1 GB volného prostoru na pevném disku pro instalaci,

  • další požadavky na volné místo na disku vyplývají z velikosti zpracovávaných dat,

  • monitor s rozlišením minimálně 1400×900 (WSXGA a vyšší).při použití monitoru s vyšší jemností obrazu (např. 4k rozlišení) bude v operačním systému nutné přizpůsobit rozlišení aplikace.

Dále doporučujeme:

  • velkokapacitní zálohovací zařízení (např. zapisovatelná CD, DVD, USB flash disk, externí HDD),

  • zajistit zdroj nepřetržitého napájení (UPS) jako ochranu dat před nečekanými výpadky.

Síťová instalace – klient

Minimální požadovaná konfigurace:

  • požadavky na konfiguraci odpovídají lokální instalaci,

  • odpovídající síťové nebo internetové připojení k serveru.

Síťová instalace – server

Minimální požadovaná konfigurace:

  • osobní počítač s 2jádrovým procesorem Intel, AMD nebo kompatibilním s frekvencí minimálně 2 GHz,

  • 4 GB RAM (2 GB pro Flexi),

  • 10 GB volného prostoru na pevném disku,

  • další požadavky na volné místo na disku vyplývají z velikosti zpracovávaných dat,

  • velkokapacitní zálohovací zařízení (např. zapisovatelná CD, DVD, externí HDD),

  • kvalitní 100Mbitové či 1Gbitové síťové prvky.

Dále doporučujeme:

  • vyhradit počítač pouze pro funkci serveru,

  • zvolit server z nabídky renomovaného výrobce serverů,

  • zajistit zdroj nepřetržitého napájení (UPS) jako ochranu dat před nečekanými výpadky,

  • deaktivovat funkce vypínání pevných disků a síťových karet z důvodu úspory energie,

  • v případě Windows nastavit správně antivir.

Systémové a hardwarové požadavky pro běh serveru Flexi se mohou lišit dle vašich potřeb, konkrétní výrobce nedoporučíme, pokud však nastíníte využití jsme schopni alespoň poradit ohledně minimální specifikace. Co se týče ABRA Flexi, je možné ho provozovat na Raspberry Pi 4 (od 1 500 Kč) až po server s 2 Xeon procesory, kde se cena může pohybovat okolo 50 000 Kč. V případě zájmu o individuální konzultaci či další informace se obraťte na nejbližšího prodejce produktu. Pomůžeme vám upřesnit konfiguraci či posoudíme její vhodnost.

Našli jste odpověď?