Přeskočit na hlavní obsah
Všechny sbírkyBáze znalostí desktopové aplikace (GUI)Instalace a provoz
Aktualizace ABRA Flexi na verzi 2022.5.x na operačním systému Linux
Aktualizace ABRA Flexi na verzi 2022.5.x na operačním systému Linux

Automatická aktualizace na Linuxu momentálně není podporována, proto verze nebude prozatím nasazena do RPM/DEB repozitářů.

Ota Rádl avatar
Autor: Ota Rádl
Aktualizováno před více než týdnem

ABRA Flexi od verze 2022.5.0 podporuje pouze PostgreSQL 10 - 13. Tedy verze 2022.5.x, s verzí PostgreSQL 9.x není možné provozovat. Automatická aktualizace na Linuxu momentálně není podporována, proto verze nebude prozatím nasazena do RPM/DEB repozitářů.

Pokud tuto verzi ABRA Flexi nutně potřebujete nasadit, postupujte dle tohoto návodu.

Postup instalace

Nejprve doporučujeme prostudovat přehled změn ve verzích 2022.5.x. Přehled změn naleznete v sekci O programu - Verze.

Pro úspěšnou aktualizaci ABRA Flexi bude nutné aplikaci kompletně odstranit a před opětovnou instalací nainstalovat PostgreSQL 13.

Kroky instalace

  1. vytvořte zálohu dat všech firem z datového zdroje.

    • bez zálohy dat ztratíte veškerá účtovaná data

  2. odinstalujte ABRA Flexi včetně dat

    • ABRA Flexi je nutné kompletně odstranit

  3. odinstalujte původní verzi PostgreSQL

    • pokud instalovaná verze PostgreSQL není 13, proveďte odinstalaci.

  4. nainstalujte PostgreSQL 13

  5. aktualizujte/změňte Javu

    • V Debianu 10/11 není k dispozici Java 8, Debian používá Javu 11. ABRA Flexi prozatím vyžaduje Java 8, proveďte změnu.

  6. nainstalujte nově ABRA Flexi

  7. naimportujte licenci ABRA Flexi

    • jelikož se jedná o "novou" instalaci aplikace bude nutné znovu importovat licenci a aplikaci aktivovat.

    • v případě, že licenci potřebujete zaslat, kontaktujte naše obchodní oddělení na emailovou adresu obchodflexi@abra.eu či telefonicky +420 371 124 340.

  8. obnovte zálohy dat vytvořené v prvním kroce

  9. nastavte hesla a typy uživatelů

    • součástí záloh firem ABRA Flexi nejsou hesla uživatelů a typy uživatelů.

    • uživatelé tedy budou bez hesel a dokud jim nějaké nenastavíte, nelze se na ně v obnovených datech přihlásit.

FAQ

Proč není repozitář aktuální?

Jedná se o záměr, protože automatické aktualizace, které se tím vynutí, musejí být spolehlivé. Při vydávání nové verze postupujeme takto.

Jaké jsou systémové požadavky?

ABRA Flexi nelze spustit z důvodu dvou verzí Javy.

Pokud jsou v počítači nainstalované dvě verze Javy a ABRA Flexi nelze spustit, pravděpodobně se snaží spustit s nepodporovanou Javou. Je nutné v souboru /etc/default/flexibee odkomentovat Flexi_java a nastavit cestu k Javě, kterou má ABR Flexi použít.

Jak obnovit zálohu dat na serveru?

Pokud selže obnova v aplikaci serveru je řešením obnovit zálohu dat pomocí API.

Dochází ke špatnému vykreslení ABRA Flexi.

Na některých Linuxových distribucích může dojít ke špatnému vykreslení fontů v políčkách aplikace, řešení naleznete zde.

Potřebujete poradit?

V případě dotazů k aplikaci nás kontaktujte na podporaflexi@abra.eu případně prostřednictvím chat okna v pravém dolním rohu.

Dostali jste odpověď na svou otázku?